BETA

15th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [15/03/19 12:38 PM] with 'Major Outage'

Issue has been resolved at [15/03/19 12:39 PM]