BETA

25th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [25/08/18 03:04 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [25/08/18 03:08 PM]