BETA

25th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [25/08/18 11:18 AM] with 'Major Outage'

Issue has been resolved at [25/08/18 11:20 AM]