BETA

24th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [24/08/18 02:18 PM] with 'Major Outage'

Issue has been resolved at [24/08/18 02:20 PM]