BETA

15th March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [15/03/19 11:41 AM] with 'Partial Outage'

Issue has been resolved at [15/03/19 11:42 AM]