BETA

24th August 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [24/08/18 01:07 PM] with 'Major Outage'

Issue has been resolved at [24/08/18 01:08 PM]