BETA

15th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [15/03/19 11:39 AM] with 'Partial Outage'

Issue has been resolved at [15/03/19 11:41 AM]