BETA

11th June 2019

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [11/06/19 12:16 PM] with 'Major Outage'

Issue has been resolved at [11/06/19 12:33 PM]