BETA

23rd August 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [23/08/18 07:31 PM] with 'Partial Outage'

Issue has been resolved at [23/08/18 07:42 PM]