BETA

23rd August 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [23/08/18 01:01 PM] with 'Major Outage'

Issue has been resolved at [23/08/18 01:02 PM]