BETA

15th April 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/04/17 08:33 PM] with 'Partial Outage'

Issue has been resolved at [15/04/17 08:34 PM]