BETA

23rd August 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [23/08/18 12:13 AM] with 'Partial Outage'

Issue has been resolved at [23/08/18 12:15 AM]