BETA

21st August 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [21/08/18 05:23 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/08/18 05:24 PM]