BETA

21st August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/08/18 03:04 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/08/18 03:06 PM]