BETA

21st August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/08/18 01:44 PM] with 'Major Outage'

Issue has been resolved at [21/08/18 01:48 PM]