BETA

21st August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [21/08/18 10:48 AM] with 'Major Outage'

Issue has been resolved at [21/08/18 10:49 AM]