BETA

21st August 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [21/08/18 10:03 AM] with 'Partial Outage'

Issue has been resolved at [21/08/18 10:04 AM]