BETA

20th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [20/08/18 10:36 PM] with 'Major Outage'

Issue has been resolved at [20/08/18 10:37 PM]