BETA

20th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [20/08/18 02:30 PM] with 'Major Outage'

Issue has been resolved at [20/08/18 02:32 PM]