BETA

15th April 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [15/04/17 08:18 PM] with 'Partial Outage'

Issue has been resolved at [15/04/17 08:19 PM]