BETA Singapore cluster       Mumbai cluster

3rd June 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [03/06/19 02:38 PM] with 'Partial Outage'

Issue has been resolved at [03/06/19 02:42 PM]