BETA

19th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [19/08/18 01:36 PM] with 'Partial Outage'

Issue has been resolved at [19/08/18 01:38 PM]