BETA

15th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/03/19 11:25 AM] with 'Partial Outage'

Issue has been resolved at [15/03/19 11:26 AM]