BETA Singapore cluster       Mumbai cluster

1st June 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [01/06/19 12:21 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [01/06/19 02:25 PM]