BETA

15th April 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [15/04/17 08:10 PM] with 'Major Outage'

Issue has been resolved at [15/04/17 08:12 PM]