BETA Singapore cluster       Mumbai cluster

31st May 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [31/05/19 09:27 PM] with 'Partial Outage'

Issue has been resolved at [31/05/19 09:31 PM]