BETA Singapore cluster       Mumbai cluster

30th May 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [30/05/19 10:05 AM] with 'Partial Outage'

Issue has been resolved at [30/05/19 10:06 AM]