BETA

18th August 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [18/08/18 10:54 PM] with 'Partial Outage'

Issue has been resolved at [18/08/18 10:55 PM]