BETA Singapore cluster       Mumbai cluster

27th May 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/05/19 04:47 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [18/06/19 11:13 PM]