BETA Singapore cluster       Mumbai cluster

27th May 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [27/05/19 04:41 PM] with 'Partial Outage'

Issue has been resolved at [27/05/19 04:56 PM]