BETA

18th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [18/08/18 11:25 AM] with 'Partial Outage'

Issue has been resolved at [18/08/18 11:27 AM]