BETA

15th April 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [15/04/17 08:03 PM] with 'Partial Outage'

Issue has been resolved at [15/04/17 08:07 PM]