BETA

17th August 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [17/08/18 03:33 PM] with 'Partial Outage'

Issue has been resolved at [17/08/18 03:40 PM]