BETA Singapore cluster       Mumbai cluster

27th May 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/05/19 02:27 PM] with 'Major Outage'

Issue has been resolved at [27/05/19 04:35 PM]