BETA Singapore cluster       Mumbai cluster

27th May 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [27/05/19 02:27 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [27/05/19 04:36 PM]