BETA Singapore cluster       Mumbai cluster

22nd May 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [22/05/19 07:02 AM] with 'Partial Outage'

Issue has been resolved at [22/05/19 07:03 AM]