BETA Singapore cluster       Mumbai cluster

20th May 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [20/05/19 12:36 PM] with 'Partial Outage'

Issue has been resolved at [20/05/19 12:37 PM]