BETA

16th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/08/18 03:40 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/08/18 03:42 PM]