BETA

16th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [16/08/18 02:48 PM] with 'Partial Outage'

Issue has been resolved at [16/08/18 02:51 PM]