BETA Singapore cluster       Mumbai cluster

16th May 2019

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [16/05/19 10:45 PM] with 'Major Outage'

Issue has been resolved at [16/05/19 10:47 PM]