BETA

16th August 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [16/08/18 12:24 PM] with 'Major Outage'

Issue has been resolved at [16/08/18 12:28 PM]