BETA

16th August 2018

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [16/08/18 10:30 AM] with 'Major Outage'

Issue has been resolved at [16/08/18 10:36 AM]