BETA

14th April 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/04/17 05:26 PM] with 'Major Outage'

Issue has been resolved at [14/04/17 05:27 PM]