BETA

17th July 2016

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [17/07/16 12:06 AM] with 'Partial Outage'

Issue has been resolved at [17/07/16 12:09 AM]