BETA

12th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [12/05/19 10:15 AM] with 'Partial Outage'

Issue has been resolved at [12/05/19 10:18 AM]