BETA

14th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/08/18 02:07 PM] with 'Major Outage'

Issue has been resolved at [14/08/18 02:27 PM]