BETA

14th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/08/18 01:58 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/08/18 02:03 PM]