BETA

15th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [15/03/19 07:05 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/03/19 07:13 AM]