BETA

14th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/08/18 12:26 PM] with 'Partial Outage'

Issue has been resolved at [14/08/18 12:27 PM]