BETA

14th August 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [14/08/18 11:37 AM] with 'Partial Outage'

Issue has been resolved at [14/08/18 11:58 AM]